Type in the full discussion title or a part of it.
Discussion Title Created date
rcall "out of range" problem
Hi all AVR users The problem is as follows (AVR Studio 4.08 @ mega64/128) : When using "rcall" to call a subroutine you will get a problem when program gets larger and larger and...
Thu. Feb 26, 2004 - 10:15 AM
LCD routines
Hi, I am having troubles writing to a standard 4*20 lcd using 4 bit mode. I am using AtmanAVR and the the functions that is built in the IDE. The problem is that lcd_init locks up...
Tue. Feb 17, 2004 - 10:05 PM
Fuse bit settings for ATMEGA 16
Hi, does anyone have the correct configuration of fuse bits for ponyprog for ATMEGA16 when 16 Mhz external crystal oscillator is desired. Morten
Fri. Feb 13, 2004 - 02:16 PM
How to recover avr when fuse bits are programmed
Hi (anyone) ! Unfortunately I have programmed my fuse in a way so I cant get contact with my ATMEGA16 via my ISP programmer using PonyProg. By now I have locked 3 AVR's and i am...
Tue. Feb 10, 2004 - 07:05 PM
sqare root assembler code
I have written a square root routine (input 40 bit integer) in assember (in AVR studio) that I use in RMS calculations. "Problem" is that the routine takes up to 3mS (7.37MHz). Is...
Tue. Jan 6, 2004 - 09:13 AM
AVR studio 4 and AT tiny 12
Hi, I have a problem with choosing the AVR simulation for AT tiny 12 when I create a new project. The device is listed but not highlighted and not choose able. Does any one know...
Sat. May 24, 2003 - 08:26 AM
Newbe & porting ;) please help
Can someone help a newbi at gcc ;) I have this code example & i want to port it to gcc asm: ldi ZH,HIGH(TEST2<<1) ldi ZL,loW(TEST1<<1)...
Mon. Jan 6, 2003 - 11:43 PM
Newbe & porting ;) please help
Can someone help a newbi at gcc ;) I have this code example & i want to port it to gcc asm: ldi ZH,HIGH(TEST2<<1) ldi ZL,loW(TEST1<<1)...
Mon. Jan 6, 2003 - 11:42 PM
Missing $(AVR)/avrfreaks/avr_make
Having installed AVRGcc 3.0.2 (Linux, mandrake 9.0) I seem to be unable to compile due to a missing $(AVR)/avrfreaks/avr_make. Any ideas on how to get that one, as it seems rather...
Tue. Nov 26, 2002 - 09:00 AM
USB interface to Mega128
Hi there. I was wondering if anybody ever had interfaced a Mega128 to the USB port of a PC? Does anybody know anything on that topic? Please enlighten me with links, hints or...
Mon. Nov 11, 2002 - 02:03 AM
UART and simulator
I'm desperately trying to simulate UART-reception in a 2313 using AVR Studio, and the UART is set up correctly. I've even used sample code found here, but the RXC-bit never gets...
Thu. Oct 25, 2001 - 04:07 PM