Post Created date
Bootloader code copy causing hard fault
NOW WORKING.  I don't know exactly what I changed, but the code is the same as above and everything now works.  It seems to be reliable and never fails to transfer the...
Saturday, 18 June 2022 - 17:01
Modifying available USB Middleware to become MIDI (Audio) class
Anybody have any info that can help me here?  Thanks.
Thursday, 7 April 2022 - 14:03
USB as MIDI using ASF4?
Thanks for the reply.  The document is for Host USB, but I'm using the USB as a device only so when connected to a computer it should use the standard Windows driver used for...
Thursday, 31 March 2022 - 18:02
Function specific optimization not working
awneil wrote:So why posting in the AVR section?   I felt the attribute command was generic enough to post here since it is a compiler directive and not really related to the...
Friday, 4 February 2022 - 21:46
Function specific optimization not working
skeeve wrote: How fast is your clock? At 20 MHz, a cycle is 50 ns.   As a workaround to the original complaint, you might put the function in a separate file.   Also,...
Friday, 4 February 2022 - 21:44
Function specific optimization not working
N.Winterbottom wrote: awneil wrote: Sounds like  a job for assembler   Sounds more like a job for  __builtin_avr_delay_cycles() defined as:    extern...
Friday, 4 February 2022 - 20:52
Function specific optimization not working
I looked into doing it all in assembly, and yes, it would be better, but looking at the dissassembly, that code seems so all over the place.  Too much to post.  With the...
Friday, 4 February 2022 - 20:32
Function specific optimization not working
I determine the optimization using this code which must put out specific size pulses on to a port. when globally optimized for O3 a pulse is about 100ns, but goes out to 1.88us...
Friday, 4 February 2022 - 19:36
Setting outputs on GPIO in code
Thank you for the suggestion.  I discovered that what was happening was this line was forcing the gpio to go into an input mode even though I used the pin commands to make it...
Thursday, 20 May 2021 - 14:23
problems outputting a clock to a pin - ATSAMS70Q21B
ki0bk wrote: I have no experience with SAM parts, so just a guess, did you make the pin an output?   Jim     I just gave that a try by adding this code:  ...
Friday, 19 July 2019 - 22:59
quick question about const* hw
westfw wrote: I need the hw name for UART3 but in general it would be nice to know where these defines are.  Doesn't Atmel Studio's "Goto Implementation" find it for you?...
Wednesday, 17 July 2019 - 17:43
ASF4 SPI CS Problem
I used Start when I set up my SPI using the Pin Configurator.  I set the 3 SPI pins to "peripheral", but then just manually set my chip select line to digital output and...
Wednesday, 17 July 2019 - 06:58

Pages