Post Created date
ATSAMD20 and "Keep timers running in stop mode"
Quote: Still unclear   JLink always physically attached. When initially turned on buzzer works; I have a button that when pressed sends a command via SPI. When pressing F5 (...
Wednesday, 6 January 2021 - 09:49
ATSAMD20 and "Keep timers running in stop mode"
Buzzer only works after a hard reset.
Tuesday, 5 January 2021 - 18:01
ATSAMD20 and "Keep timers running in stop mode"
I started (F5) then stopped (ctrl shift F5) and buzzer doesn't work.
Tuesday, 5 January 2021 - 17:44
ATSAMD20 and "Keep timers running in stop mode"
Happens after detaching AND during debugging, even after setting dbgrun to 1.
Tuesday, 5 January 2021 - 17:41
ATSAMD20 and "Keep timers running in stop mode"
Lajon wrote:   So the only place you can expect to set this bit is between the tc_init and the tc_enable calls. Also, why does it matter, are you planning to do a lot of...
Tuesday, 5 January 2021 - 16:26
ATSAMD20 and "Keep timers running in stop mode"
meolsen wrote: XY problem - Wikipedia   Indeed! Apologies for any annoyance. As a noob I'm also trying to understand how things work so as to better my understanding and...
Tuesday, 5 January 2021 - 16:24
ATSAMD20 and "Keep timers running in stop mode"
To the address the larger question, my main issue is that after detaching the debugger the buzzer no longer works. I'm trying to figure out why this happens.   The chip...
Tuesday, 5 January 2021 - 16:17
ATSAMD20 and "Keep timers running in stop mode"
meolsen wrote:If you check the I/O view, does the bit set? If it doesn't, can you toggle it in the Ioview?   It does. However, after following this lead I've also tried...
Tuesday, 5 January 2021 - 15:31
ATSAMD20 and "Keep timers running in stop mode"
Thanks for that. I set it with...     RTC->MODE0.DBGCTRL.bit.DBGRUN = 1;   RTC->MODE1.DBGCTRL.bit.DBGRUN = 1;   RTC->MODE2.DBGCTRL.bit....
Tuesday, 5 January 2021 - 14:54