Post Created date
(Outdated) Script for building AVR-GCC 4.5.1 on Linux
Thanks a lot. Got it working on Fedora core 8 (fc8), 64 bit machine. :D
Tue. Apr 8, 2008 - 03:39 AM
Using serial port (rs232) terminals in Linux
Thanks for the suggestions and links. I would like to use a program, instead of having to program my own. I've been spoiled by HTerm in windows. 0=) I'm hoping Cutecom works...
Thu. Mar 13, 2008 - 10:45 PM
Help with inline functions
yes, you are correct. (edited it in the original post). But the inlining still doesn't seem to be working. =\
Thu. Aug 2, 2007 - 07:25 AM
uC only works correctly when reset twice
I think I solved the problem... my TIMER1_OVF_vect interrupt function was apparently hogging up cycles. I was using buffered USART transmit/receive functions and using the...
Wed. Aug 1, 2007 - 11:36 PM
help with TTL / RS232 level converter (MAX211)
Yeah, I have it in a circuit as on p10, with SNDN and EN connected to ground. I found the C2+ pin (15) was accidently shorted to ground through a solder bridge, but even after I...
Mon. Jul 9, 2007 - 10:09 PM
stk500 ISP programming on external pcb?
I think somehow the lock bit got set on the 8515 chip, disabling programming. =\ Put the chip back in the STK board and fixed it. Thanks for the help
Wed. May 9, 2007 - 12:20 AM
stk500 ISP programming on external pcb?
My multimeter shows that the vtg pin from the isp header is powered to +5V from the stk board I've also tried using an external power supply for the chip, connecting the grounds...
Tue. May 8, 2007 - 11:58 PM
stk500 ISP programming on external pcb?
Thanks for the quick reply. I have the crystal connected between xtal1 and xtal2, have 22pF caps to ground from xtal1 and xtal2. I have the fuse bits set to use the external...
Tue. May 8, 2007 - 11:05 PM
AVRDUDE no longer works
How recently does AVRDude do this? I have the 5.3.1 version of AVRDude (in WINAVR 20070122) and '-c stk500' doesn't automatically probe for the v2 firmware
Tue. Mar 13, 2007 - 04:40 AM
Note: STK500 FW 2.00 and avrdude Problem
Thanks a lot. :) I got my WinAVR setup working now using "-c STK500v2"
Sat. Feb 17, 2007 - 03:39 AM