Type in the full discussion title or a part of it.
Discussion Title Created date
Xmega and SDRAM
Anybody do this?
Fri. Jun 5, 2009 - 06:58 PM
AtXMega and DMA
I have an array: const unsigned char sequence[] = {0,1,2,3,4,5,6,7,8,9}; And I want to transfer each element of the array to a port output using DMA over a period of time and...
Wed. May 13, 2009 - 08:31 PM
ATXmega64A1-AU Getting started
So I just got some of these chips last week and soldered one to a test board. Tested the JTAG and everything looks fine so far. So I just started my first line of code and looking...
Thu. Apr 30, 2009 - 08:24 PM
UART RS232 Problems
I have a project with an atmega using the serial port. I have a max3232 logic level converter for RS232. I communictate fine with some PC software I am using and have used a few...
Fri. Mar 27, 2009 - 06:50 PM
GDBSERVER
I am trying to run gdbserver in order to debug some code. I use the com port on NGW100 and I get a segmentation error. ~ # cd usr /usr # dir -sh: dir: not found /usr # cd.. -sh:...
Mon. Apr 28, 2008 - 05:03 PM
AVR32 --> NGW100
I just got a NGW100 board and powered it up. I can connect to it via serial, telnet, ftp, http. I compiled a hello word program using command line and downloaded it to the board...
Fri. Apr 25, 2008 - 04:31 PM
Atmega1280 low frequency crystal capacitance
I connected a 32768 Hz crystal to the Atmega1280 without any external capacitors, and it oscillated at a freq about 200khz. I assumed that there were alrready 12.5pF caps internal...
Mon. Dec 17, 2007 - 04:13 PM
SPI Port Atmega1280 TQFP100
I am trying to output a byte consitantly out of the SPI port on the uC. serial_enable(); txchar_serial('1'); DDRK |= 0x80; PORTK &= ~0x80; DDRB |= 0x06; DDRB...
Thu. Dec 13, 2007 - 02:58 PM
.data section in external ram
How do I place everything in external ram? I use this in the makefile: EXTMEMOPTS = -Wl,--section-start,.data=0x802200,--defsym=__heap_end=0x80ffff but still get this in my map...
Tue. Dec 11, 2007 - 07:48 PM
Atmega1280 JTAG mkII programming problems
I am using an Atmage1280-16AI 100-TQFP. AVR Studio 4.12 SP4. VCC is 3.3V on my board. All JTAG connections are verified. TDI - pin 90 TDO - pin 91 TMS - pin 92 TCK - pin 93 nSRST...
Fri. Dec 7, 2007 - 02:12 PM
Bootloader (storing wrong data)
I'm using Atmega324P with avrgcc. I have made a bootloader and I get a random FFFF in flash once in a while. The data packet going to the microcontroller was verified and I am...
Thu. Aug 16, 2007 - 05:47 PM
Watchdog
I get the following error when using the watchdog functions. It worked okay with the newer version of winavr, but when I reverted back to an older version, problems. void...
Wed. Jul 25, 2007 - 03:43 PM

Pages