Type in the full discussion title or a part of it.
Discussion Title Created date
Solved: U8G2 causes high power consumption while powerdown - Atmega 1284P
After hours of trying i figured out what the cause of the high power consumption is. But i dont have a glue how i can fix this.   When i put my power down routine after "u8g2...
Sunday, 10 February 2019 - 14:45
Variable gets incremented without doing this in the code.
I just wonder "what the f***". What is goind on ? "count" gets incremented still when it is commented out.   I added "WTF" to verify that the program has compiled.   Now...
Thursday, 24 January 2019 - 08:40
input capture interrupts starts late - TCNT1 is reset to late.
I have a problem:   Since the interrupt for the input capture starts to late, i can only reset TNCT1 to 0 after a certain time. So there are some counts that are lost. This...
Tuesday, 22 January 2019 - 10:54
Get more Flash-/RAMusage out of a ATMega32u4?
Hi Freaks!   If the search would have been a useful tool, i would have used it. But its as bad as Google (gets me more than 12k of hits for "32u4 size").   My problem: I...
Sunday, 13 January 2019 - 08:21
delayMicroseconds() does not delay as it should
Hi there, i already struggle hours with this strange problem. Please see the comment in the code for the details. Note that these are actually 2 sourcecodes right after each other...
Tuesday, 20 February 2018 - 13:02
Code does not work a all when there is an array of volatile int with atmega328p
Hi,   why in the world is this code not working at all (!) - not even the setup - when i put in the assignment at line 60???? #include "pins_arduino.h" #include "arduino.h...
Saturday, 25 March 2017 - 09:34
A modulos operation, takes 40us on Atmega328p?
Hi there freaks, hours are ticking by like seconds and Google presents only garbage... I now tried a lot of combinations on a simple if-clause and came to the point that this is a...
Wednesday, 22 March 2017 - 20:53