Post Created date
Help reading AT24C512 serial eeprom module
Again, thanks for your help. But it must be apparent by now that I have pretty much memorized the datasheet and the uC manual. My code is directly from table 75 in the atmega16...
Wednesday, 25 March 2009 - 14:19
Help reading AT24C512 serial eeprom module
David, Thanks. I will try this. I would much rather understand how the registers are working, but I think I am going to have to give up on this ideal and take the easy way out.
Wednesday, 25 March 2009 - 13:44
Help reading AT24C512 serial eeprom module
Thanks for your help.
Wednesday, 25 March 2009 - 12:50
Help reading AT24C512 serial eeprom module
David, I believe that I found the missing TWEA last night, but unfortunately I am still reading FF for all memory spaces. This might mean that I am not writing, or that I am not...
Wednesday, 25 March 2009 - 12:06
Help reading AT24C512 serial eeprom module
Hello, If you have experience with this chip, please take a moment to look at my code below. I am trying to read data from a serial eeprom AT24C512. All of the status codes...
Wednesday, 25 March 2009 - 01:27
Help reading AT24C512 serial eeprom module
Stan, Point well taken. My response was rude. But you probably shouldn't assume so much about the questioner.
Monday, 23 March 2009 - 20:42
Help reading AT24C512 serial eeprom module
David, Read the question, THEN try to answer it.
Monday, 23 March 2009 - 15:56
Help reading AT24C512 serial eeprom module
Thanks David. So I assume that you are familiar with the chip. So the question is... when can the uC read the TWDR register? How does the uC know when the next byte is ready to...
Monday, 23 March 2009 - 14:04
Looking for information on two wire serial eeprom
Let me re-phrase this question more specifically.... In setting the registers for the TWI, I haven't found anything in the uC manual which describes how to set the ports for SDA...
Sunday, 22 March 2009 - 17:38
ATMEGA16 erratic behavior with 8MHz crystal
Thanks for the help.
Saturday, 21 March 2009 - 22:25
USART receive function causes hyperterminal to crash
Sorry js, I totally missed that. And it was the first response. This selective observation could also be why I can't get my circuit to work.
Thursday, 12 March 2009 - 12:15
USART receive function causes hyperterminal to crash
Well Mr/Ms buffi, the hyperterminal "flow control" setting of "hardware" was the problem, as you suggested. I changed this setting to "none" and everything works. Thanks for...
Thursday, 12 March 2009 - 01:11

Pages