Type in the full discussion title or a part of it.
Discussion Title Created date
[TUT][SOFT][C] Learning C on the PC
Before attempting to program an AVR in C it's best to actually learn the basics of the C language on your PC. While it is possible to learn C using an AVR the fact that you don't...
Saturday, 27 October 2012 - 18:10
Memory window bug
Atmel, IS it just me or do you find with AS6+JTAGICEmkII+mega16 that if in your debug session you try to have three memory windows visible, one set to "prog FLASH". on to "eeprom...
Friday, 26 October 2012 - 18:49
relax and .lss files
I guess I may be the last one to have spotted this but is everyone else aware that when you use -Wl,-relax the .lss file can no longer be used. I was looking at the intermediate ....
Wednesday, 24 October 2012 - 11:17
[TUT][HARD]Using JTACICEmkII (+ Atmel tools) with Virtualbox
Having just had occasion to try and use my JTAGICEmkII with AS6 running in a Windows XP virtual machine in VirtualBox I was told that it needed a firmware upgrade. The problem was...
Friday, 19 October 2012 - 10:52
IF YOU HAVE A PROBLEM WITH AS 5/6/6.1 UPGRADE TO AS 6.2
Subject says it all I posted this as I just read the 10 gazillionth thread where the solution was simply to upgrade from a 5.x/6.0/6.1 version to 6.2. It seems the message about...
Friday, 24 August 2012 - 08:59
Fixing AS4.19 so it works with WinAVR
In the transition from 4.18SP3 to 4.19 Atmel made a change to AVR Studio so that it would no longer automatically look for WinAVR. Yet many people still want to use 4.19 and...
Friday, 6 July 2012 - 08:30
Welcome to the AVR Studio 5 and Atmel Studio 6 and Atmel Studio 7 and..Forum!
Welcome to the AVR Studio 5 and Atmel Studio 6 Forum! 1. Please note that the best way to get useful answers on the AVR Forum is to follow some simple guidelines found in a...
Thursday, 1 March 2012 - 11:43
Xmega beginner question about IO map
I'm just starting to play with my very first Xmega (an xmega32A4U) and my first question: Did I miss something - what lives between 0x0020..0x002F?. I understand: 0x0000..0x000F...
Tuesday, 7 February 2012 - 22:08
[not a] Bug in GCC [but I still think it should be!]
Well who'd have thought. While developing my "mad simulator" idea I hit a bug in 4.3.3 (WinAVR20100110) that is shown by this: #include int main(void) { switch (PINA) {...
Wednesday, 2 November 2011 - 18:03
The slowest most pointless AVR program ever
Here's a bit of extreme silliness I wrote over the weekend... So first I wrote this AVR program: #include __attribute__((noinline)) void mydelay(void) { volatile uint16_t i...
Monday, 31 October 2011 - 17:02
Fix for Atmel - "no debugging available"
This AS5 thing just about wound me off the end stop with it's spurious ""No debugging information available" for a project built with -g so when it just happened I checked the...
Tuesday, 25 October 2011 - 10:27
An irritation in AS5
I just did something I thought was obvious in AS5 but it wouldn't let me. I started a new avr-gcc executable project so it created a .c file for me. I then wanted to add a .S file...
Monday, 12 September 2011 - 12:16

Pages