Type in the full discussion title or a part of it.
Discussion Title Created date
Static variable init inside ISR - split from LDS thread
//Here every 50ms static uint8_t u8_100msCounter = 0; //100ms tick if (u8_100msCounter) u8_100msCounter--;I may be wrong here, but when will this ever run? ...
Sat. Apr 15, 2017 - 04:31 PM
Harmonic frequencies
I sometimes play with simple medium wave receivers for my grandson. As there is a very weak signal in our flat, I recently made a simple signal generator with Avr. It produces a...
Sat. Feb 13, 2016 - 09:01 AM
Arduino-PC communication
Hi, I have a question about Arduino (with which I have no experience).   Suppose I want to use "Dccduino UNO R3 ATmega328" without Arduino IDE. I can write and compile the...
Fri. May 22, 2015 - 08:15 PM
AvrOspII + fusebits
Hi all, I have recommended AvrOspII programmer software to a friend of mine and now he has reported a strange error. In "Fuse Bits" option the main textbox is empty (see attached...
Sat. Mar 19, 2011 - 11:21 AM
Master SPI on Mega88 not working
Hi all, I am testing SPI master on my experimental board with this code //Avrstudio 4.14.589 //Winavr 20071221 //f_osc=8MHz #include #include #define...
Wed. Feb 10, 2010 - 09:07 AM
Local array problem
Hi, I have a theoretical question. I declare an initialised local array in main() and then display all bytes on Lcd. // Avrstudio 4.14.589 // Winavr 20071221 // Attiny2313 // 1...
Thu. Sep 17, 2009 - 08:58 AM
AVR910 and programming speed
Hi, I have made a AVR910 programmer (hw) by Klaus Leidinger http://www.klaus-leidinger.de/mp/Mikrocontroller/AVR-Prog/AVR-Programmer.html I have tested it with Avr-OspII, Avrdude...
Tue. Jul 28, 2009 - 03:14 PM
Avrdude and Megabootloader
Hi, I use Mega88 with Megabootloader. With Avr-Osp II all works well. Now I test Avrdude without a succes. I try to read flash. I see no errors in Avrdude report, but in the file...
Mon. May 25, 2009 - 04:16 PM
Error in .lss file?
Hi, I use Winavr + Avrstudio My program compiled without warning and works well. But in .lss file I found line "brne .+92". Relative branch should be max +64. What is wrong...
Tue. Oct 21, 2008 - 08:30 AM
DC amplifier with opamp LM358 problem
Hi, I need a simple DC amplifier with gain = 10 input voltage = 1 to 250 mV. I have tested opamp LM358, but only one of my 3 pieces has linear relation between input voltage and...
Mon. Jun 2, 2008 - 07:44 AM
XDIV and UART problem
Atmega128 Crystal 16MHz Avrstudio + Winavr When using 16 MHz clock, I send bytes to PC succesfully. But as soon as I divide clock in XDIV I get all zeroes in the terminal. What is...
Tue. Mar 11, 2008 - 02:36 PM
How to get a constant from C to Asm
Hello, I have a constant X defined in main file. I cannot find how to use it in assembler. /*** file main.c ***/ #define X 120 /*** file asm1.s ***/ .func foo foo:...
Fri. Jan 25, 2008 - 07:51 AM

Pages