Type in the full discussion title or a part of it.
Discussion Title Created date
some advice wanted on where to put defines
I am busy writing code for my compas sensor and would like to know if there is a common practice in what things I can best put at what place. I have basically 3 files: - HMC5843.h...
Monday, 23 January 2012 - 21:20
preprocesor expression and cpu defines
I have the following very long line of code: #if !defined (__AVR_ATmega640__)...
Sunday, 18 December 2011 - 12:33
explanation on the UART stop bits
OK, I'm a bit puzzled I have a GPS receiver module that has the setting 9600buad, 8data bits, 0 stop bits and no parity. I'm using an ATmega1281 and with that I can only select 1...
Saturday, 12 November 2011 - 15:56
experience with LIS331DLH
I'm wondering if anybody here has some experience with the LIS331DLH from ST micro. I'm intending to use it through the TWI interface as the SPI interface is already very busy and...
Wednesday, 22 June 2011 - 07:50
Attiny85 Vref seems way off
I'm making a circuit to monitor a battery. When I measure on the input pin with a scope(or volt meter) I have a nice 680mV. (with a resistive divider) If I use the formula (Vin *...
Monday, 20 June 2011 - 19:47
looking for 3d compas code/formulas
I have a HMC5843 3D compass module. I have been able to use the internal calibration and have made a 2D compass. That was easy as a lot of topics on a number of fora and...
Thursday, 24 March 2011 - 18:45
Getting bit by pointers
I have been "playing" all day with pointers trying to make some code that can scan different ports. I have to be doing something very simple and for all fundamentally wrong as I...
Sunday, 5 December 2010 - 21:21
having trouble with inline
I have been playing for a while now with the inline functions and having difficulties understanding why certain things are happening. I have a module (c+h file) with an ISR inside...
Saturday, 20 November 2010 - 20:47
spontanious wrong programming
Just to share with other users: Yesterday evening, I tried to program a complete good and working board. I had 5V USB supply connected and was running from that. I used AVR Studio...
Tuesday, 3 August 2010 - 05:41
creating uniform code
I'm looking for a simple but clear way to make code work for multiple processors. Up till now I have always rewritten my code from cratch when I changed processor but that is...
Friday, 21 May 2010 - 05:42
TWI/I2C and multiple supplies
A while ago this question has also been asked, but I could not find it back. I have a Atmega1281 running on a 5V supply. I have a 4K7 pull-up (to 5V) on both SCL and SDA. I have...
Tuesday, 23 March 2010 - 20:36
Fatfs maximum files in root
I'm wondering if there is a maximum number of files that is allowed to be placed in the root of a SD/MMC card. I'm working on a simple datalogger and want to make a number of...
Tuesday, 11 August 2009 - 12:29

Pages