Type in the full discussion title or a part of it.
Discussion Title Created date
NaN macros not working correctly?
I'm running AS 7.0.1645 toolchain 7.0.895   I have an un-initialized float nanCheck that the debugger reports as -nan(0x7fffff). But isnan( nanCheck ) returns 0 // (...
Wednesday, 11 July 2018 - 17:31
AtmelICE no longer detects devices. Error 4109 - Solved
I have two different boards, one using a SAM4N8 and another using SAMD20G15.  Both used to work/debug/program fine.  15 boards in total. Now today, none of them will...
Thursday, 4 January 2018 - 20:23
AtmelICE no longer detects devices. Error 4109
Sorry, I meant to post this in the SAM community, but I can't see how to delete my post.   I have two different boards, one using a SAM4N8 and another using SAMD20G15. ...
Thursday, 4 January 2018 - 20:17
input pins using ASF? -- solved
I'm on a sam4n8 and simply trying to read the input pins.  I've tried using direct port access and failed, now trying using ASF and also failing.  ARGH! I can configure...
Wednesday, 16 August 2017 - 17:27
SAM4n trouble reading gpio -- solved
I'm trying to read a few gpio inputs pa0-pa3.  I have various logic level voltages asserted to the different pins so I can see a pattern when it starts working.  But for...
Friday, 11 August 2017 - 20:44
Blips and AVR studio5 on win7 64bit
On a fresh install of AVR studio5 on win7 64 bit, I can not get BLIPS to find the XML data files for the devices. I've attached screen shots of both the error and the directory...
Wednesday, 26 October 2011 - 23:02
Start without debug VS AVR Programming
We are having a weird issue, where our code runs fine if we use "debug and break" or "start without debug". But if we try to just program the chip, the program fails to operate...
Tuesday, 11 October 2011 - 17:36
how to get high byte and low byte in GCC assembler?
Are there equivalent functions in gcc assembler to the AVR assembler for high and low? From the AVR manual: Quote:Functions LOW(expression) returns the low byte of an...
Friday, 17 June 2011 - 18:41
How do I include BLIPS into my C project?
I would like the BLIPS.asm bootloader to be part of my C project. But when I add it to the solution explorer, it doesn't get assembled during the build process. There is no blips...
Thursday, 16 June 2011 - 23:28
display corruption problems
Has anyone run into display corruption problems on AS5? Beta1 had lots of issues of blanking upon updating, for me. Like the memory watch window would go blank when I hit a break...
Friday, 3 June 2011 - 16:28