Type in the full discussion title or a part of it.
Discussion Title Created date
MALLOC use
1)I'm just experimenting w/ malloc using winavr 20090303 and PN. I'm using the syntax i found on other posts, it compiles but it goes into err handler. Missing something ? 2) Is...
Wednesday, 7 April 2010 - 09:36
FATFS f_read problem
Well here we go: MP3 player, winavr 20090303, PN, 3.3V system using 2GB SD, vs1011E and xmega16A4, FATFS 7e. Read only. inits, mounts, and f_open correctly. #define...
Tuesday, 6 April 2010 - 08:09
ISR push pop optimize
I have WinAvr 20090303 and PN. Is there any way to keep the compiler from push / pop so many regs. ( even if only a few are used ?
Tuesday, 6 April 2010 - 06:23
[Solved - for now]FATFS f_open f_read problems
I'm trying to read from a 2 GB Patriot SD, I have FATFS 7.0e, xmega16A4, PN. It Inits, and mounts correctly. So problem must be somewhere in f_open. I use read_only mode Returned...
Sunday, 4 April 2010 - 05:44
TFT and LCD enclosures
I'm having a hard time finding a company that fits an LCD into plastic enclosures. I'm working with 20x4 LCDs and 240x320 (TFTs), and I need company names that will do mounting of...
Monday, 22 March 2010 - 19:09
Pointer increment problem
After i load OCR1a i need lcg_ptr to inc and point to next address, but i can't do it. The *.lss code shows beginning address of ptr[], NOT lcg_ptr. It would work on 1st pass,...
Monday, 8 March 2010 - 07:26
Mixing C and Ass.
Using Winavr and Studio, If I create a GCC pjt. with .S as kernel file ( but i need to call a c function )are there any advantages to doing it that way other than I guess i don't...
Tuesday, 2 March 2010 - 10:06
Studio 4 Simulator math ( solved )
I have Studio 4.18 and I'm trying to simulate Atmel appNote200 ( 16 x 16 mult unsigned ). The stack pointer value shows up in reg. view, but after that as i step thru code no regs...
Saturday, 27 February 2010 - 22:27
XMEGA16 RTC ISR
Tryin' for a RTC to LCD . I init the RTC of my xmega16 correctly for a 1s ISR www.avrfreaks.net/index.php?name... 1) but the LCD counts down ( after the 1st second ), 9... 0 !!?...
Tuesday, 9 February 2010 - 08:33
Xmega16 RTC init
I thought the code below was all i needed to init the RTC, but i guess i'm missing something !!? I'm using an RTC ISR to drive a LCD display, but the LCD doesn't do anything ( LCD...
Tuesday, 9 February 2010 - 05:04
PDI connection after programming
My xmega16 runs its code after programming, but ONLY if its PDI I/F is still tied to the mkii ISP. How do i connect PDI after disconnecting ISP ?
Wednesday, 3 February 2010 - 07:17
Conditional compile for SPI
I'm trying to make a driver for the xmega256 and m644 in ref. to SPI. The code below is in SPI.c, and their proto's. are in SPI.h, but it won't compile. What am i doin wrong?? MCU...
Friday, 22 January 2010 - 23:58

Pages