Type in the full discussion title or a part of it.
Discussion Title Created date
Which debuggers work with AS7/1645 ?
I came back to programming AVR-devices.   It is an several years old design based on an ATmega32.   I have a whole bunch of debuggers available, but none is working...
Sun. Feb 11, 2018 - 03:22 PM
JTAGICE3 upgrade failes WDAPI1200.DLL missing
I ran into problems when trying to connect a JTAGICE3 to AS 7.0/1645   Upgrade within AS70 failed, therefore I tried to do it form commandline.   For this, I downloaded...
Sun. Feb 11, 2018 - 03:16 PM
static library: undefined reference error ...
I am trying to bring some functions into a static library. But I get undefined reference errors for all functions form the library which are used in the main project (AS 7.0)...
Thu. Feb 8, 2018 - 04:33 PM
Tool for setting up your µC ...
I have been pretty inactive with my µC-projects for the last years.   Now, I want a revival for an old  project  powered by a Atmega32.   I remember, I...
Tue. Feb 6, 2018 - 09:42 PM
AT90CANxxx - Error management on CAN-Bus
A few years before I started using the AT90CANxxx types for my own CAN-based projects.   This worked okay for me, as I used the same bit-rate setting for all my nodes at...
Sun. Feb 8, 2015 - 08:25 PM
Which is the best bootloader for a AT90CANxxx ?
I have developed a USB<->CAN-Bus "DOngle" which works good for now. One is for my lab, 3 or 4 more are working somewhere else.   for these, I would like to provide an...
Sun. Feb 8, 2015 - 07:45 PM
Wrong line highlighted while debugging
I updated to AS 6.2 These days and try now to debug an older Project. Firmware of my JTAGICE3 was also updated.   Sometimes my Debugging worked okay, but now  I land on...
Mon. Dec 22, 2014 - 08:36 AM
breakpoints cannot be reached are out-of-Sync
I updated to AS 6.2 These days and try now to debug an older Project. Firmware of my JTAGICE3 was also updated.   Sometimes my Debugging worked okay, but now  I land on...
Sun. Dec 21, 2014 - 04:56 PM
USART: example needed for interrupt-driven transmission
I have problems sending data through the USART. The data should be sent in packets of 14 bytes. But the process simply does not stop. I am sure that something is wrong with my...
Fri. Jan 3, 2014 - 05:31 PM
debugging/watching classes in AS6.1
It is the first time I use C++ for one of my projects. Even more stupid, I tried to modify an existing (and more or less working) project and replaced parts of the code for use of...
Wed. Jan 1, 2014 - 09:25 PM
error compiling wdt_enable in c++
this line wdt_enable(WDTO_500ms); raises an error at compile-time: Quote:Fehler 2 1761 : cast from pointer to smaller type 'uint16_t' (aka 'unsigned short') loses information Z...
Wed. Jan 1, 2014 - 06:25 PM
library: is the correct device necessary ?
I have written some functions for a circular buffer. These functions should be available as a library for further usage in several Projects. The library contains no hradware...
Sat. Dec 28, 2013 - 05:23 PM

Pages