Type in the full discussion title or a part of it.
Discussion Title Created date
Programming Blues JTAG mkII and ATMega8515
I normally work with AT32UC3A series, but I am building a lighting project using someone else design, that uses an ATMega8515.  I have a JTAGICE mkII that works fine with the...
Mon. Nov 20, 2017 - 06:22 PM
How does one change the ADC clock?
I am having a problem with the ADC hanging on EOC - All the examples I have found for the UC3 having it running at the internal clock or using PM for setting the clocks.  I...
Mon. Sep 18, 2017 - 11:58 AM
Solution - Setting up a UC3A PWM with sysclk and not pm
It has taken me about 3 weeks to finally get this running.  Thanks to mikech for the final clue.   The attached code sets up a PWM using sysclk functions to setup the...
Mon. May 15, 2017 - 10:07 PM
UC3A PWM - running, but cannot change duty cycle
It has taken me a couple of weeks to figure out - looking at numerous examples and the data sheet to get a PWM running under PLL while only using sysclk functions, not power...
Mon. May 15, 2017 - 12:59 AM
What's the fastest square wave you have gotten from a UC3
Just curious - I am running a UC3A1512 with a 12 MHz oscillator.  Using the gpio_tgl command in a while loop, I have reached 1.6 MHz square wave output.   Anyone with a...
Fri. May 12, 2017 - 06:59 PM
tracking down an "undeclared interrupt"
Is there a way to see what led to an undeclared interrupt?  A program that was working (before I changed hard drives and version of Atmel Studio) is now throwing an "...
Fri. May 5, 2017 - 06:11 PM
Trying to get a PWM to work
I have been trying for a few days now to get a PWM to work on an AT32uc3a1512 with zero success.  Well that's not totally true, I can get my code to compile without errors,...
Tue. Apr 25, 2017 - 12:04 AM
MORE AT32UC3A1512 External INT Woos - SOLVED!!!!!
I recently posted about not being able to get external interrupts working and had a suggestion that fixed the problem - now I have run into another problem. . . .    I...
Fri. Mar 3, 2017 - 07:15 PM
AT32UC USART Selection not working
I have been working on getting the USARTs working on an AT32UC3A processor, with a few problems.  I got it to work for USART 1, non-interrupt mode.  So I decided to try...
Sun. Dec 18, 2016 - 07:00 PM
The application is in break mode
I have seen several treads on this topic - I have yet to see an answer.  I have got this problem BIG TIME and cannot get anything done due to it!  I really need an...
Fri. Nov 11, 2016 - 01:35 AM
AT32UC3A1512 External Interrupt issues
I have done the due diligence in looking for all the examples of using the external interrupts on an AT32UC3A1512 and still I am having issues.  The issue is that in intc.c...
Wed. Jun 22, 2016 - 10:14 PM
AT32UC3A(0&1)512 Port B-3 not working
Beating my head against the wall with this one.  I was programming an 240x320 LCD display with an AT32UC3A1512, using port A0-15 for 16 bit data to the LCD.  Ran into a...
Tue. Apr 12, 2016 - 01:10 AM

Pages