Post Created date
Interruption function not working as it should
Thanks very much! I will be reading your tutorial soon!
Sunday, 19 June 2011 - 17:59
Interruption function not working as it should
Koshchi wrote: _delay_us(T); You don't want to send a variable into _delay_us(), it requires a constant known at compile time. Quote:When the ATmega328P enters INT1 or INT0...
Sunday, 19 June 2011 - 03:45
Interruption function not working as it should
Hum, you're right. I've put the delay in the first line of the ISR. I have tried changing the beat++ to beat = beat + 1 and this causes no change also. Ok! Enough for today, I...
Sunday, 19 June 2011 - 03:12
[TUT][C]Optimization and the importance of volatile in GCC
Thanks for taking your time to write this tutorial! It was very helpful!
Sunday, 19 June 2011 - 02:32
Interruption function not working as it should
indianajones11 wrote:OK, what about my other questions ? Come on, don't make it a tooth pullin' session. Sorry, I didn't see your edit! Yes I'm using switches on both...
Sunday, 19 June 2011 - 02:29
Interruption function not working as it should
Thanks! Now I get it about what is and why use volatile! I've added the line above also and no change. I've compiled using -O0 optimization (off) and no changes also. AVR Studio...
Sunday, 19 June 2011 - 02:14
Interruption function not working as it should
Thanks very much for the welcome and the suggestion! Unfortunately it didn't work. Also when I try to see the Disassembler, I get some "151: File not Found" errors in the middle...
Sunday, 19 June 2011 - 01:42