Type in the full discussion title or a part of it.
Discussion Title Created date
Attiny 1634 Clock Frequency
I am trying to use the internal 8 MHz oscillator but both the CTC interrupt rate and a simple for loop timer indicate that it is closer to 22.7 KHz.   When OCR1A is set to...
Saturday, 26 November 2016 - 16:20
JTAGICE MKII and IAR Workbench
WOW! I have been away from this site for a while and what a change!   I have a client that needs minor revisions to code that was written about 10 years ago using IAR...
Wednesday, 7 January 2015 - 01:29
Butterfly Voltage Measurements
The Butterfly uses J407-1,2 as the input for a voltage measurement. The resistance divider R212 (1.5M) and R209 (300K) scale down the voltage so it is below the selected reference...
Friday, 31 January 2014 - 18:17
Using XTAL2 to Driver Other Devices
Can the Xmega XTAL2 pin be used to drive other devices as on the Atmega's? If so, what is the maximum drive and how susceptible is it to line capacitance? Maybe it is best to run...
Tuesday, 8 October 2013 - 21:39
SD Card on Xmega, AVR32, SAM
We intend to use an SD card to log data from an MCU and then remove the SD and read it on a PC. Are there libraries available to implement a file system on the Xmega, AVR32 or SAM...
Friday, 13 September 2013 - 21:25
LDO Outputs
I have two sources of 5v on a PCB. One is from an on-board LDO and the other is from an external DC supply. If the external supply is attached and there is no input to the LDO...
Monday, 8 July 2013 - 18:51
STK500 cannot program or read fuses (signature OK)
This subject has been covered before but I could not find an answer that solved my problem. (Maybe this should be in the AVR Forum?) I am programming an AT90S8515 with an STK500...
Wednesday, 25 July 2012 - 23:39
Switch to Studio 5?
I am currently using Studio 4.19. o mostly C (occassionaly assy for critical code) o JTAGICE mkII and sometimes a Dragon o Atmega, Xmega, Tiny, AT90USB About 8-10 months...
Monday, 19 March 2012 - 15:21
AT25DF021
This is a follow-up to my earlier post on the AVR Forum. We understand the problem better and this is probably the better forum for discussion. We are using a AT90USB1287 and have...
Wednesday, 14 March 2012 - 03:09
SPI with Studio and Eclipse
We have code that is talking to an external AT25DF021 SPI flash memory. When the code is compiled with AVRDude under Eclipse on a Mac writes/reads work as expected. When compiled...
Tuesday, 13 March 2012 - 19:17
Mega64 UART Problem
When receiving serial bytes at 115200 baud the result is always 0xFF regardless of the data sent. Some of the bytes are not received at all (i.e. if 5 bytes are sent often less...
Saturday, 10 March 2012 - 23:11
INT0 Keeps Triggering
I am using a Mega64 with a TL16C552A UART. When the UART receives data it notifies the Mega64 by issuing a positive pulse on INT0. The problem is that as soon as the interrupts...
Wednesday, 29 February 2012 - 18:15

Pages