Post Created date
ABOUT SSD1306
With a Mega 328?? It only has 1K of memory but as David points out you have unsigned char array[1024]; . .  for(j=0;j<1024;j++)  etc. So if your data takes up ALL of...
Wednesday, 17 April 2019 - 08:27
interfacing multiple shift registers with atmega128
can you suggest any latest alternative for atmega128 The Mega128 is an extremely OLD chip, the newer ones are ATmega1281/2561 (same pinout) or the 100 pins ATmega640/1280/2560
Wednesday, 17 April 2019 - 06:07
Atmega328P Fast PWM OC1A Problem (again)
Maybe I don't understand but how is #if 1 defined?   You should post a full program that someone may want to try out.
Wednesday, 17 April 2019 - 06:04
ABOUT SSD1306
it is a atmega328p.    so your AVR needs 4096 SRAM bytes because of the reserving of two 1024-byte arrays in main(), along with more housekeeping SRAM memory.
Wednesday, 17 April 2019 - 00:28
Why is _delay_ms_ behave unpredictably ?
Look in the debug folder.
Monday, 15 April 2019 - 06:21
silly question about USB terminal
Maybe something like this? https://sites.google.com/site/co...
Saturday, 13 April 2019 - 03:48
Servo motor datasheet
Would you like fries with that?
Friday, 12 April 2019 - 22:47
MPLAB snap to atmega328pb program and debugWIRE
Not sure why after posting the above, I get the Unable to send eMail, Contact Site Admin messages. We are all getting that and not getting any emails notifications for a bout 2...
Thursday, 11 April 2019 - 20:54
Interfacing ESP8266 with atmega8
Nothing to do with Studio, moving to AVR forum.
Wednesday, 10 April 2019 - 20:51
ATMEL Studio 7 - win7/32 Problem with sub's return
If there is a short on portd pin/s then maybe the processor just freezes because the supply drops internally.   HOWEVER if the code runs with with the inline delay that...
Wednesday, 10 April 2019 - 20:47
ATMEL Studio 7 - win7/32 Problem with sub's return
I have cleaned up your code (removed unnecessary bits) and run it on the STK500 (had to invert the bits for that) and it all works well at 1MHz.   Leds flash at about 300ms...
Wednesday, 10 April 2019 - 03:38
ATMEL Studio 7 - win7/32 Problem with sub's return
What do you have on PORTB? If you have a short circuit between pins or to one of the power supply pins then the power could die and the chip reset when you output state 42 or 50.
Tuesday, 9 April 2019 - 23:13

Pages