WSN Monitor in BC 1.14.0 does not log packets

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have the LwMesh WSN demo running on a Raven (End Device) and RCB (Coordinator), but notice that the packet log function in the WSN Monitor out of BC 1.14 (v2.2.1.92) does not actually log packets. The packets.log and wsnMonitor.log continue to be 0 bytes with no packet log information. This has since been confirmed by Atmel wireless support, and they entered it as a bug, but no date for a fix (not holding my breath).

I had BC 1.12.0 previously and the packet log function in that WSN Monitor (v2.2.1.66) does work, but there are some additional functions in WSN Monitor 2.2.1.92 that are nice.

I would like to have the latest WSN Monitor that properly logs packets, but non-current versions of BC (v1.13.0 ? others ?) are not available for download for me to check.

Anyone know where to get, or have, a version of WSN Monitor > 2.2.1.66 but < 2.2.1.92 ?

- john

Last Edited: Fri. Oct 16, 2015 - 02:03 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I will check when I'm back in the office on Monday.

NOTE: I no longer actively read this forum. Please ask your question on www.eevblog.com/forum if you want my answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Here is WSNMonitor_Setup_2.2.1.80.exe from BC v1.13.0. See if this works for you.

NOTE: I no longer actively read this forum. Please ask your question on www.eevblog.com/forum if you want my answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Alex,

Sorry for the delay. Looks like 2.2.1.80 does log packets, though right now it only says "wait:" and a timestamp. I had modified the demo source code to read the thermistor and do the Steinhart-Hart for temperature, and to also actually measure the battery voltage, and I had also modified the protocol\wsndemo_base.xml to deal with the new values and formats. When I uninstalled 2.2.1.92 it deleted this file, and of course I can't remember exactly what changes I had made to it. Doh !

Anyway, I think it is working since packet.log is no longer totally empty, though I won't know for sure until I figure out what changes I have to put back into wsndemo_base.xml. Thanks for your help.

- john

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK, naturally, there is an issue with the WSN Monitor 2.2.1.80 exe file.

After installation, it does not display the node parameters you select from the drop-down. When you enable the node parameters Light, Temperature or Battery, the values last sent by that node should be displayed next to the little icon for that node. Additionally, in the Node Parameters window there should be a line item for the above parameters, and in the Node History window there should be a tab for each parameter which displays a graph of the values over time. None of this happens in 2.2.1.80, though it does happen in 2.2.1.92.

However, I notice that the .66 and .92 BitCloud distributions I have include a WSNMonitorSetup_..jar file in addition to the .exe. Can you please see if there is .jar file in your distribution also ?

I only mention this because the 2.2.1.66 (exe plus jar) does have the above items working and it seems unlikely that they would have just got broken in 2.2.1.80, so maybe the jar file is required for proper installation. Thanks,

- john

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Jar file is included for use on Linux, it is not required and not used for installation from exe.

But if you want it, here you go.

Why not just use a Python script like this one and collect all the data you want?

NOTE: I no longer actively read this forum. Please ask your question on www.eevblog.com/forum if you want my answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello, i use this module ATSAMR21B18-MZ210PA, 

the software "wsn monitor" not function, it recognised the serial port but not work 

Please can you help me?

I use atmel studio to flash the module with miwi