Split: same54p20a_flash.ld

Go To Last Post
12 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi !

 

I am using ATMEL STUDIO latest version 7.0 and OS IN WINDOWS 10.

 I opened same54p20a_flash.ld using notepad in the folder.

Now the problem is ATMEL studio is not recognizing the file and popping that file cannot find during building project.

 

file extension is  "same54p20a_flash.ld" before and after opening in notepad.

 

can anybody help me to solve the issue. 

 

Thank you in advance

This topic has a solution.

Gujjar Vijay

Last Edited: Thu. Jan 4, 2018 - 09:22 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

GUJJAR VIJAY wrote:
I opened same54p20a_flash.ld using notepad in the folder.

Now the problem is ATMEL studio is not recognizing the file and popping that file cannot find during building project.

Just to be clear:  was it doing that before you opened the file in notepad ?

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

GUJJAR VIJAY wrote:
popping that file

What do you mean by "popping a file" in this context?

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The full quote is

GUJJAR VIJAY wrote:
ATMEL studio is ... popping that file cannot find during building project

I think what the OP means is that AS is popping-up a message saying that the file cannot be found?

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Issue get solved Thank you , 

Gujjar Vijay

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello All ,
I am using SAME54 xplained pro development board and its has ATSAME54P20A ( 128 pins ) but for my project
I am using ATSAMD51J18A ( 64 pins ).Doubt is,if I generate USART driver in ATMEL studio using SAME54 xplained pro
development board, can I able  to use this driver for ATSAMD51J18A with same hardware design as in SAME54 xplained  pro.
 
Thank you in advance.

Gujjar Vijay

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Issue get solved Thank you

 

Gujjar Vijay

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

For the benefit of other readers with the same problem who may find this, please describe how the issue was solved.

 

And please mark the thread as solved: https://www.avrfreaks.net/comment...

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

same54p20a_flash.ld file was configured to open other than Notepad and due to that file extension was changed and was not recognizing from ATMEL project.

 

Gujjar Vijay

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does that mean that you have your Windows File Explorer set to hide the extensions of "known" files?

 

I think this is a great example of why that is a Really Bad Idea!

 

I suggest that you disable this option immediately!

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Dear All ,

 

Facing I2C driver reset issue ... could you please help me..

 

Developed I2C driver to read temperature by external  ADC  in atmel studio and code is working fine and no reset of i2c happening.

But when I use  same files in Eclipse environment using eclipse MAKE files getting i2c reset.

 

target : ATSAMD51J18A

 

Thanks in advance

Gujjar Vijay

Last Edited: Mon. Mar 19, 2018 - 02:48 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

one topic per thread please :)

jeff