SAMG55 I2SC in Master mode - disabling clocks

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

I am using the I2SC module on the SAMG55 (Xplained Pro) with the G55 as the I2S master, transmitting data to an I2S amplifier (NXP TFA9882)

 

The clock is taken from the Peripheral Clock with Master Clock enabled (I2SC_MR.IMCKMODE = 1) and I2SC_MR.IMCKFS set to 31 (1:1024)

 

Everything is working well except for one thing - I don't seem to be able to disable the clocks (both BCK and WS) once they've been enabled...

Is there anything to consider except for writing a one to I2SC_CR.CKDIS?

 

The motivation to disable the clocks is that the I2S amplifier enters power-down mode once it detects no activity on the BCK line

 

Thanks!
Moti

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK, it seems that I found a workaround for this -

 

I am disabling/enabling the I2SC peripheral clock (in the PMC) by writing PMC_PCDR/PMC_PCER

 

Moti

Last Edited: Mon. Feb 22, 2016 - 01:13 PM