How to approach the Ping Test for SAM V71

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 I tried the ping test for SAM V71 using LWIP. But I am not able to ping the PC from the SAM V71 board. I don't know how to approach the ping test. It would help if there are any links or suggestions. Thanks:).

The steps which I have Tried :

1. Initialization of Board IP
2. Initialization of Destination IP
3. Protocol used for sending is: UDP Protocol

Code : check attachments

Attachment(s): 

Last Edited: Tue. Sep 22, 2020 - 10:01 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So what debugging have you done ?

 

Doesn't LWIP provide any diagnostic output ?

 

Is your unit doing anything at all on the line ?

 

How To Debug

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@12345

 

You have no valid reason to report Andy's response to your post.

 

Moderator

 

Ross McKenzie ValuSoft Melbourne Australia