FATFS SD/MMC example : does not detect FAT table on SD card

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Please help, this is the only case that does not work  from many code examples I tried from ASF3 library.

ASF3 FATFS example with SD card on SAME70 Xplained board does not recognize the FAT system on the card...

Card is mounted OK but doesn't see FAT table. It failed reading the first signature byte (reading is OK but the byte is not the one expected).  I tried to fake recognition by commenting out the code which reads the signature in ff.c file but the code "outsmarted" me - it failed on all subsequent FAT table readings :)

This is strange because I have SD card RAW example writing/reading binary operations and my PC sees FAT system on all those SD cards which I tried with this example (FAT and FAT32).

I even added f_mkfs() formatting code in the same FATFS with SD example to make sure that FAT table will be acceptable to the FATFS library... yet, after formatting returned with great success, the subsequent FAT table reading failed...

So,

  1. code reports the SD card is mounted OK
  2. number of pre-formated and tested SD cards inserted,
  3. also tried FATFS routine f_mkfs() formatting the card during the initialization, yet
  4. code fails to recognize FAT table (the reading itself did not fail).

Can somebody help please ?

 

Vlad.

Last Edited: Thu. Jul 18, 2019 - 06:30 AM