is Cortex-M7 hex programming functional in AS7, too early?

Go To Last Post
10 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have a Cortex-M7 connected to AS7 but AS7 does not program the chip.  AS7 reads registers ok but the programming portion fails.  Does AS7 support M7 devices?  Is Cortex-M7 integration in AS7 still in progress? 

 

Last Edited: Sat. May 21, 2016 - 05:23 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I use AS7 (build 594) to program SAME70. So yes it works.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What JTAG probe do you use?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

jtagice3, but you can't program via jtag interface. Only via SWD interface, as mentioned in datasheet:
"The JTAG debug ports TDI, TDO, TMS and TCK are inactive. They are provided for Boundary Scan Manufacturing Test purposes only"

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

That is true.  I meant what probe or interface do you use for debugging?  SAM-ICE, J-Link?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

As I said, JTAGICE3

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I suspect there is a failure with J-Link in AS7 from my observations.  I missed JTAGICE3 sorry! 
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I think you are right. At least as long as it concerns the latest AS7 version (see my post somewhere above). For me at least the 'Erase program only' works.

 

Best Regards

Markus

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I opened a ticket with Atmel's support.  The tech was able to reproduce the problem so the problem seems confirmed.  I'm waiting to hear the next step.  Does anyone on the Atmel Studio team lurk on the forum? 

 

This capture shows a programming failure followed by a successful program.  Just by reopening the program window, program works. https://www.youtube.com/watch?v=...

This captures shows you can start a debug session if you manually program the chip first.  https://www.youtube.com/watch?v=...

 

Last Edited: Sat. May 28, 2016 - 02:18 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My J-Link Plus works well (much better than EDBG), but loses connection with the target occasionally when using AS7.