Atmel Studio can't find any edbg/medbg/samice tools

1 post / 0 new
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just had an issue where Atmel studio 7 wouldn't enumerate any connected tools/programmers. 

atfw - l

showed the devices, but atmel studio wouldn't list them as Available Tools.  I reinstalled, repaired, cleared all caches...really everything I could think of.  Finally I reached out to support and their suggestion worked, but it was one I didn't find under any searches in 2 days of trying, so I'm sharing the accepted answer for posterity, hopefully to save someone else from 2 days of frustration.


Answer below:

Thank you for contacting Microchip Technical Support Team.


I understand that you are using latest Atmel Studio version 7.0. 1931. Also, you have tried clean and reinstallation of Atmel Studio.


Could you please check whether SAM-ICE (and other tools) listed in the device manager?


If SAM-ICE is listed in Device manager but does not detected in

Atmel Studio means there is a possibility for duplicate entry of “JLinkARM.dll”



Atmel Studio should use the Jlink shipped with C:\Program Files (x86)\Atmel\Studio\7.0\atbackend\ JLinkARM.dll


If duplicate entry of “JlinkARM.dll” is found in the any other location, for example: C:\Windows\System32 or C:\Windows\SysWOW64 should be removed.


For identify which JLinkARM.dll file is loaded for Atmel Studio you can use Process Explorer:


For the same:


• Launch Atmel Studio.

• Connect SAM-ICE.

• Open procexp application.

• Select Process Explorer Search.

• Search for 'JLinkARM.dll'.

• Check which dll is used for Atmel Studio. It should use the dll

file available in the atbackend folder for proper working. Please find the

attachment for reference.

• Delete all other duplicate JLinkARM.dll file.


Kindly let us know whether it helps.