Atmel Studio 7 file and directory error

1 post / 0 new
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am sorry if this is a repost, but I had posted on another forum and they told me that it would be better suited here. I have tried searching and have not found an answer that helps and have tried the Atmel Studio 7 documentation which has not helped either. I have the SAM4N Xplained Pro board with Atmel Studio 7 and cannot compile any code. I have tried both creating and using the already made projects. When I try to build the project it gives me the following error listed in the build below. I have also tried to build it myself from the command line to no success.  This is for a college class as we just switched over from another board and this problem has persisted on both a laptop and desktop both with Windows 8.1. 


The closest I have gotten is when changing the compile path below for the full filename extension below. The compiler spits an error that the header in sysclk.c (which is "#include <sysclk.h>") does not exist. However it is in the same file path as the the sysclk.c while also giving and error for a sysclk.o not existing error (which I cannot find in any file path). Thank you for any help, I am really lost and don't really know where else to go. I have also included the file below, if that could be of any assistance?


------ Build started: Project: 1, Configuration: Debug ARM ------
Build started.
Project "1.cproj" (default targets):
Target "PreBuildEvent" skipped, due to false condition; ('$(PreBuildEvent)'!='') was evaluated as (''!='').
Target "CoreBuild" in file "C:\Program Files (x86)\Atmel\Studio\7.0\Vs\Compiler.targets" from project "C:\Users\Cole\Documents\Atmel Studio\7.0\GETTING-STARTED1\GETTING-STARTED1\1.cproj" (target "Build" depends on it):
    Using "RunCompilerTask" task from assembly "C:\Program Files (x86)\Atmel\Studio\7.0\Extensions\Application\AvrGCC.dll".
    Task "RunCompilerTask"
        Shell Utils Path C:\Program Files (x86)\Atmel\Studio\7.0\shellUtils
        C:\Program Files (x86)\Atmel\Studio\7.0\shellUtils\make.exe all 
        Building file: ../src/ASF/common/services/clock/sam4n/sysclk.c
        Invoking: ARM/GNU C Compiler : 4.9.3
        "C:\Program Files (x86)\Atmel\Studio\7.0\toolchain\arm\arm-gnu-toolchain\bin\arm-none-eabi-gcc.exe"  -x c -mthumb -D__SAM4N16C__ -DDEBUG -D__SAM4N16C__ -Dscanf=iscanf -DARM_MATH_CM4=true -Dprintf=iprintf -DBOARD=SAM4N_XPLAINED_PRO  -I"../sam/applications/getting-started/sam4n16c_sam4n_xplained_pro" -I"../src/ASF/common/utils" -I"../src/ASF/common/services/serial/sam_uart" -I"../src/ASF/sam/drivers/pmc" -I"../src/ASF/sam/boards" -I"../src/ASF/sam/drivers/pio" -I"../src/ASF/sam/boards/sam4n_xplained_pro" -I"../src/ASF/common/boards" -I"../src/ASF/sam/utils/header_files" -I"../src/ASF/sam/drivers/tc" -I"../src/ASF/sam/utils/cmsis/sam4n/source/templates" -I"../src/ASF/common/services/ioport" -I"../src/ASF/sam/utils/cmsis/sam4n/include" -I"../src/ASF/thirdparty/CMSIS/Include" -I"../src/config" -I"../src/ASF/thirdparty/CMSIS/Lib/GCC" -I"../src" -I"../src/ASF/common/services/clock" -I"../src/ASF/common/utils/stdio/stdio_serial" -I"../src/ASF/sam/utils" -I"../src/ASF/sam/utils/preprocessor" -I"../src/ASF/common/services/serial" -I"../src/ASF/sam/drivers/usart" -I"../src/ASF/sam/drivers/uart"  -O0 -fdata-sections -ffunction-sections -mlong-calls -Wall -mcpu=cortex-m4 -c -pipe -fno-strict-aliasing -Wall -Wstrict-prototypes -Wmissing-prototypes -Werror-implicit-function-declaration -Wpointer-arith -std=gnu99 -ffunction-sections -fdata-sections -Wchar-subscripts -Wcomment -Wformat=2 -Wimplicit-int -Wmain -Wparentheses -Wsequence-point -Wreturn-type -Wswitch -Wtrigraphs -Wunused -Wuninitialized -Wunknown-pragmas -Wfloat-equal -Wundef -Wshadow -Wbad-function-cast -Wwrite-strings -Wsign-compare -Waggregate-return  -Wmissing-declarations -Wformat -Wmissing-format-attribute -Wno-deprecated-declarations -Wpacked -Wredundant-decls -Wnested-externs -Wlong-long -Wunreachable-code -Wcast-align --param max-inline-insns-single=500 -MD -MP -MF "src/ASF/common/services/clock/sam4n/sysclk.d" -MT"src/ASF/common/services/clock/sam4n/sysclk.d" -MT"src/ASF/common/services/clock/sam4n/sysclk.o"   -o "src/ASF/common/services/clock/sam4n/sysclk.o" "../src/ASF/common/services/clock/sam4n/sysclk.c" 
arm-none-eabi-gcc.exe(0,0): error: ../src/ASF/common/services/clock/sam4n/sysclk.c: No such file or directory
arm-none-eabi-gcc.exe(0,0): warning: '-x c' after last input file has no effect
arm-none-eabi-gcc.exe(0,0): error: no input files
        compilation terminated.
        make: *** [src/ASF/common/services/clock/sam4n/sysclk.o] Error 1
        The command exited with code 2.
    Done executing task "RunCompilerTask" -- FAILED.
Done building target "CoreBuild" in project "1.cproj" -- FAILED.
Done building project "1.cproj" -- FAILED.

========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========