Unable to configure DMA for ADC using Atmel Start

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0


Hi guys, I am working on a project that requires the adc, and I want to use the DMA. 

I have been able to get the adc to work using the sync drivers (I haven't tried async), but when I use the DMA no conversion seems to be happening. 

The callback is never ran, and now values are put into the buffer besides 0.

 

Here is my adc configuration:

 

Here's My DMA configuration

 

 

Here is the setup and callback

 

 

 

Any help would be greatly appreciated, this has been driving me crazy.

 

Last Edited: Tue. Jun 29, 2021 - 07:30 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Which AVR is this for?

 

 

Keys to wealth:

Invest for cash flow, not capital gains!

Wealth is attracted, not chased! 

Income is proportional to how many you serve!

If you want something you've never had...

...you must be willing to do something you've never done!

Lets go Brandon!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sorry, I am using the Samd21ja18A on the Xplained pro board

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'll move this to the proper forum

 

Jim - Moderator

I would rather attempt something great and fail, than attempt nothing and succeed - Fortune Cookie

 

"The critical shortage here is not stuff, but time." - Johan Ekdahl

 

"Step N is required before you can do step N+1!" - ka7ehk

 

"If you want a career with a known path - become an undertaker. Dead people don't sue!" - Kartman

"Why is there a "Highway to Hell" and only a "Stairway to Heaven"? A prediction of the expected traffic load?"  - Lee "theusch"

 

Speak sweetly. It makes your words easier to digest when at a later date you have to eat them ;-)  - Source Unknown

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB, RSLogix user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
	/* Enable ADC freerun mode in order to make example work */

You don't have "Free Running Mode" enabled.

/Lars