ATSAMB11 MR210CA OTA profile along with Serial chat profile not working

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello all,

I have SAMB11 Xplained Pro, MR210CA development kit. I have used Serial chat profile in Multirole peripheral multiconnect application, everything is working ok with this. Then i Have merged OTA upgrade profile in code to support OTA updates. But then when I connect to xplained Pro device with microchip smart connect Application, OTA update is not working. also Serial chat profile working is not stable. After debugging i have found that there is issue in connection handle of OTA profile. mismatch in  current params handled with connection handle of OTA characteristics and service. but unable to find any solution to resolve this. please help me..

Last Edited: Sun. Aug 26, 2018 - 06:09 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

(yes, I know this is a year-old post.  Sorry.)

 

One of the things which USED to be true (no idea if it still is) is that the OTA update code would NOT WORK if compiled with any optimization other than -O1 or -O0.  I don't know what the issue was (is?), but one of the symptoms was "the example works, but when I try to use the code in my own app, it doesn't"... and then finding that all the files are optimized to -Os or something.  If you change the optimization on just the OTA files, that should be enough.

 

I'd love for Microchip to clean up Atmel's mess on this device.  It's horrible and poorly-documented.

 

+j