microchip_gallery.8.0.0.vsix Installation Failed

Go To Last Post
17 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm unable to install Microchip Gallery (microchip_gallery.8.0.0.vsix from https://gallery.microchip.com/packages/AtmelStudio7ExtensionManager/) using VSIX Installer.

Note, following the instructions in this article does not resolve the issue: https://microchip.secure.force.com/microchipknowledge/articles/en_US/FAQ/Installing-extensions-in-Atmel-Studio-shows-This-extension-is-not-installable-on-any-currently-installed-products

I'm using Atmel Studio 7 (build 1645) on Windows 10 x64

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Installation failed dialog

Install log

25/01/2018 11:42:33 - Microsoft VSIX Installer
25/01/2018 11:42:33 - -------------------------------------------
25/01/2018 11:42:33 - Initializing Install...
25/01/2018 11:42:33 - Extension Details...
25/01/2018 11:42:33 -     Identifier         : AtmelStudio7ExtensionManager
25/01/2018 11:42:33 -     Name               : Microchip Gallery
25/01/2018 11:42:33 -     Author             : Microchip
25/01/2018 11:42:33 -     Version            : 8.0.0
25/01/2018 11:42:33 -     Description        : Microchip Gallery
25/01/2018 11:42:33 -     Locale             : en-US
25/01/2018 11:42:33 -     MoreInfoURL        :
25/01/2018 11:42:33 -     InstalledByMSI     : False
25/01/2018 11:42:33 -     SupportedFrameworkVersionRange : [4.6,4.9]
25/01/2018 11:42:33 -
25/01/2018 11:42:33 -     SignatureState     : Unsigned
25/01/2018 11:42:33 -     Supported Products :
25/01/2018 11:42:33 -         AtmelStudio
25/01/2018 11:42:33 -             Version : [7.0]
25/01/2018 11:42:33 -
25/01/2018 11:42:33 -     References         :
25/01/2018 11:42:33 - Signature Details...
25/01/2018 11:42:33 -     Extension is not signed.
25/01/2018 11:42:33 -
25/01/2018 11:42:33 - Searching for applicable products...
25/01/2018 11:42:33 - Found installed product - Microsoft Visual Studio Community 2015
25/01/2018 11:42:33 - Found installed product - Microsoft Visual Studio 2015 Shell (Integrated)
25/01/2018 11:42:33 - Found installed product - Global Location
25/01/2018 11:42:33 - Found installed product - AtmelStudio
25/01/2018 11:42:33 - System.AggregateException: One or more errors occurred. ---> System.Xml.XmlException: The input source is not correctly formatted.
   at System.Xml.XmlExceptionHelper.ThrowXmlException(XmlDictionaryReader reader, String res, String arg1, String arg2, String arg3)
   at System.Xml.XmlBufferReader.ReadValue(XmlBinaryNodeType nodeType, ValueHandle value)
   at System.Xml.XmlBinaryReader.ReadNode()
   at System.Xml.XmlBinaryReader.Read()
   at System.Xml.XmlBaseReader.MoveToContent()
   at Microsoft.VisualStudio.ExtensionManager.BinaryHelper.ReadXmlElementList(BinaryReader reader)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtension.Read(BinaryReader reader, String installPath)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.ReadCachedInstalledExtension(Package cacheFile, CachedInstalledExtensionListIndexEntry indexEntry, Func`2 getAssetData)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.RemoveDependencyData(Package cacheFile, IDictionary`2 dependencyMap, CachedInstalledExtensionListIndexEntry entry)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.RemoveEntries(Package cacheFile, CachedInstalledExtensionListIndex index, IList`1 entriesToRemove, IDictionary`2 assetMap, IDictionary`2 dependencyMap)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.UpdateCache(Package cacheFile, CachedInstalledExtensionListIndex index, IList`1 entriesToRemove, IList`1 entriesToAdd, IList`1 installedExtensions, Boolean verifyPackComponents)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.StopScan(Int64 timestamp, ExtensionSettingsStoreList autoUpdateList)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InitializeList(CachedInstalledExtensionList cachedExtensionsList, IEnumerable`1 enabledExtensions, Boolean safeMode, Boolean isSdkList, Int64 lastExtensionsChangedTimestamp)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstalledExtensionListData.<>c__DisplayClass16_0.<CreateExtensionListData>b__2()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
   --- End of inner exception stack trace ---
   at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
   at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.PartitionedInstalledExtensionList.<>c.<BeginBatch>b__18_0(InstalledExtensionListData listData)
   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
   at System.Linq.Buffer`1..ctor(IEnumerable`1 source)
   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.PartitionedInstalledExtensionList.BeginBatch()
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.PartitionedInstalledExtensionList.TryGetValue(String identifier, IInstalledExtension& result)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.TryGetInstalledExtension(String identifier, IInstalledExtension& result)
   at VSIXInstaller.App.GetExtensionManagerForApplicableSKU(SupportedVSSKU supportedSKU, IInstallableExtension installableExtension, List`1 applicableSKUs, Boolean isRepairSupported)
   at VSIXInstaller.App.InitializeInstall(Boolean isRepairSupported)
---> (Inner Exception #0) System.Xml.XmlException: The input source is not correctly formatted.
   at System.Xml.XmlExceptionHelper.ThrowXmlException(XmlDictionaryReader reader, String res, String arg1, String arg2, String arg3)
   at System.Xml.XmlBufferReader.ReadValue(XmlBinaryNodeType nodeType, ValueHandle value)
   at System.Xml.XmlBinaryReader.ReadNode()
   at System.Xml.XmlBinaryReader.Read()
   at System.Xml.XmlBaseReader.MoveToContent()
   at Microsoft.VisualStudio.ExtensionManager.BinaryHelper.ReadXmlElementList(BinaryReader reader)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtension.Read(BinaryReader reader, String installPath)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.ReadCachedInstalledExtension(Package cacheFile, CachedInstalledExtensionListIndexEntry indexEntry, Func`2 getAssetData)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.RemoveDependencyData(Package cacheFile, IDictionary`2 dependencyMap, CachedInstalledExtensionListIndexEntry entry)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.RemoveEntries(Package cacheFile, CachedInstalledExtensionListIndex index, IList`1 entriesToRemove, IDictionary`2 assetMap, IDictionary`2 dependencyMap)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.UpdateCache(Package cacheFile, CachedInstalledExtensionListIndex index, IList`1 entriesToRemove, IList`1 entriesToAdd, IList`1 installedExtensions, Boolean verifyPackComponents)
   at Microsoft.VisualStudio.ExtensionManager.CachedInstalledExtensionList.StopScan(Int64 timestamp, ExtensionSettingsStoreList autoUpdateList)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InitializeList(CachedInstalledExtensionList cachedExtensionsList, IEnumerable`1 enabledExtensions, Boolean safeMode, Boolean isSdkList, Int64 lastExtensionsChangedTimestamp)
   at Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstalledExtensionListData.<>c__DisplayClass16_0.<CreateExtensionListData>b__2()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()<---

25/01/2018 11:42:33 - VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.
   at VSIXInstaller.App.InitializeInstall(Boolean isRepairSupported)
   at VSIXInstaller.App.InitializeInstall()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()

 

Any suggestions?

Thanks,

Graham

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

(As a slight side-note, the "Unpublished topic" message is irritating as hell.)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

use this exe: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\VSIXInstaller.exe

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks, though I already was using that.

In the end I chalked it up to some kind of Visual Studio interference, I uninstalled both Visual Studio 2015 and Atmel Studio, reinstalled Atmel Studio and then the installer worked. Not much of a solution but at least I got the extension installed that I wanted.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just had this issue with the FreeRtos+Trace extension. (freertos+trace.3.2.1.vsix) It is is an issue with having another installation of Visual Studio installed. (I have Community 2017 and MSVS2013 installed).

Save the extension to a path with no spaces (not sure if this matters, but it is what I did)..

Run Atmel Studio as administrator.

Choose tools-> Command prompt.

>VSIXInstaller.exe c:\<path to extension>\freertos+trace.3.2.1.vsix

example

>VSIXInstaller.exe c:\freertos+trace.3.2.1.vsix

Geoff S.

Lead Embedded Software Developer

Co-Owner, Motus Design Group

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am having the same issue on a Surface Book. I can't even get the VSIX installer to show a window. I tried launching it from the command line too. 

I tried reinstalling Atmel Studio and it did nothing, there are no Visual Studio instances installed

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

GrahamA wrote:

Thanks, though I already was using that.

In the end I chalked it up to some kind of Visual Studio interference, I uninstalled both Visual Studio 2015 and Atmel Studio, reinstalled Atmel Studio and then the installer worked. Not much of a solution but at least I got the extension installed that I wanted.

 

 

https://microchip.secure.force.c...

Regards,

Charles

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I followed those instructions and the VSIX did not even come up on my Surface Book.

I have successfully installed it on several other computers using the same procedure, so I think I am doing things correctly 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

levi@humaninc.com wrote:

I followed those instructions and the VSIX did not even come up on my Surface Book.

I have successfully installed it on several other computers using the same procedure, so I think I am doing things correctly 

1) When you say it did not even come up you are not seeing the install screen itself ?

2) Are there any event viewer logs which is available during that time which points to a Application error in VSIXInstaller?

Please update https://s3-us-west-2.amazonaws.com/atmel-studio/7.0.1652/as-installer-7.0.1652-web.exe it has the new Extension Manager packed with it and let us know your feedback whether you are able to install extensions within Studio from Extension Manager.

Regards,

Charles

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Someone on the AVR side seems to be having the same problem:

 

https://www.avrfreaks.net/forum/as7-updating-gallery-and-asf

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks a lot! I thought to kill visual studio 2010 on my work PC.

My case was illegal call to another version of application.

 

Hi, all!
I can’t write English well. But I love ATMEL devices.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Using that installer seems to install microchip gallery for me without having to mess with the VSIX file.

Where did you find that? The installer I downloaded from https://www.microchip.com/avr-su... is only version 7.0.1645

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Under Windows 10 the VSIX installer fails without any messages if your Windows username has a space in it.  Create a second user account without the space and try again.  I just confirmed this in a Win 10 virtual machine.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have fixed this using a different method I would like to share.

 

I have Windows 7 Pro with Atmel Studio 7.0 installed as well as Visual Studio 2012, Visual Studio 2015 and a Visual Studio Express 2013. Likewise I was getting the same error as in post #2 and I wasn't keen on re-installing Atmel Studio.

 

  • I downloaded the .vsix extensions from https://gallery.microchip.com/packages/
  • Rename the extension from .visx to .zip
  • Then Extract the zip to its own folder in %localappdata%\Atmel\AtmelStudio\7.0\Extensions\
  • Reload Atmel Studio.

.: Daniel :.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There was a recent update to Studio - I think it was supposed to fix this ... ?

 

EDIT 

 

https://community.atmel.com/foru...

 

On Fri. Jun 22, 2018 - 06:01 PM,  meolsen wrote:
Highlights of new features:

  • Advanced Software Framework 3.40.0
  • New Microchip Gallery extension

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
Last Edited: Thu. Jul 5, 2018 - 07:03 AM