Error writing a value in a ble sensortag characteristic

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,
I'm working with a rn4020 (Microchip) and with a SensorTag (Texas Instruments).
I'm trying to write a value in a characteristic but I'm not getting success.
Reading the RN4020 Datasheet, I've the following information:

By the SensorTag GATT table, I've the following information (of the Movement Service):


After reading the above information, I've tried the next commands:
(I've tried the Handle(hex) and the Type(hex) to make the command)
CHW,AA82,13F
CHW,AA82,64
CHW,003C,13F
CHW,003C,64
CHW,3C,13F
CHW,3C,64
All of the commands don't have success.
Other question that I've, is the listening of the SensorTag services. When I execute the LC command (command to list the SensorTag services) I list some UUIDs that I recognize from the SensorTag GATT but not all of them. The entire SensorTag GATT table could be consult on this link: http://www.ti.com/ww/en/wireless_connectivity/sensortag2015/tearDown.html.
 

 
Thanks for your support.
Best regards,
José Lourenço

Last Edited: Thu. Oct 15, 2015 - 09:53 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Shouldn't you be asking Texas Instruments and/or Microchip about this?

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've already posted on Microchip forum.. Tomorrow I'll try the Microchip technical support.

However, if somebody have any kind of suggestion/help, I appreciate.

 

Best reegards

Last Edited: Sun. Oct 11, 2015 - 02:37 PM