NRF24L01 Network Problem!

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

I have problem with NRF24L01 network while I'm using 1 Master (Transmitter) and more than one Salve(Receiver).

In fact, I run a network by one master and one slave. I think the Acknowledge of receivers make noise on the network.

Would mind helping me?

Thanks 

Last Edited: Fri. Oct 16, 2015 - 12:32 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Why is this in the AVR UC3 forum - doesn't seem to have anything to do with the microcontroller?

 

Note that NRF24L01 is a Nordic Semiconductor product - their support pages are here: http://www.nordicsemi.com/eng/Su...

 

Would mind helping me?

Helping you with what, exactly? You haven't given anything to go on 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Helping me with share the experiences of NRF24L01 Network. For example disable "AutoAck" or using "Pipes".

Thanks. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

no matter the brand name, disabling AutoACK, the MAC layer protocol's ACK, is very imprudent.

Pipes is proprietary to Nordic so their websites/forums are your best chance rather than here.